IncroyablePix

AttachDynamicObjectToObject

3 messages dans ce sujet

Posté(e) (modifié)

Bonjour les amis (et @Papawy :x)

 

Ça fait un moment que je n'ai rien demandé, et ça casse mon ratio;

Alors je crée des animaux, des mobs partout sur ma carte, et pour cela, j'emploie des objets, que j'aimerais attacher ensemble.

 

dBlob[blobid][oBlob] = CreateObject(2976, x, y, z + 0.29, 0.0, 0.0, 0.0);
dBlob[blobid][oBlobAttach][0] = CreateDynamicObject(19061, x, y, z, 0.0,0.0,0.0); //object(xmasorb3) (1)
dBlob[blobid][oBlobAttach][1] = CreateDynamicObject(1946, x, y, z, 0.0,0.0,0.0); //object(baskt_ball_hi) (1)
dBlob[blobid][oBlobAttach][2] = CreateDynamicObject(1946, x, y, z, 0.0,0.0,0.0); //object(baskt_ball_hi) (2)
dBlob[blobid][oBlobAttach][3] = CreateDynamicObject(3106, x, y, z, 0.0,0.0,0.0); //object(k_poolball8) (2)
dBlob[blobid][oBlobAttach][4] = CreateDynamicObject(3106, x, y, z, 0.0,0.0,0.0); //object(k_poolball8) (3)
dBlob[blobid][oBlobSword] = CreateDynamicObject(19590, x, y, z, 0.0,0.0,0.0); //object(wooziessword1) (1)
AttachDynamicObjectToObject(dBlob[blobid][oBlobAttach][0], dBlob[blobid][oBlob], 0.021, -0.04, 0.29, 0.0, 180.0, 0.0, 1);
AttachDynamicObjectToObject(dBlob[blobid][oBlobAttach][1], dBlob[blobid][oBlob], 0.0859, 0.1909, 0.4051, 0.0, 0.0, 0.0, 1);
AttachDynamicObjectToObject(dBlob[blobid][oBlobAttach][2], dBlob[blobid][oBlob], 0.2089, 0.1129, 0.4051, 0.0, 0.0, 0.0, 1);
AttachDynamicObjectToObject(dBlob[blobid][oBlobAttach][3], dBlob[blobid][oBlob], 0.144, 0.3879, 0.4621, 0.0, 0.0, 0.0, 1);
AttachDynamicObjectToObject(dBlob[blobid][oBlobAttach][4], dBlob[blobid][oBlob], 0.348, 0.256, 0.4621, 0.0, 0.0, 0.0, 1);
AttachDynamicObjectToObject(dBlob[blobid][oBlobSword], dBlob[blobid][oBlob], 0.5249, -0.1121, 0.445, 0.0, 0.0, 160.0, 1);//rx = 340.0 si attaque
SetDynamicObjectMaterialText(dBlob[blobid][oBlobAttach][1], 0," ", 80, "Arial", 1, 1, 0xFFFFFFFF, 0xFFFFFFFF, 1);
SetDynamicObjectMaterialText(dBlob[blobid][oBlobAttach][2], 0," ", 80, "Arial", 1, 1, 0xFFFFFFFF, 0xFFFFFFFF, 1);

J'ai donc fait ce genre de choses, mais le script ne semble pas très coopératif

 

En fait, les objets ne s'attachent simplement pas à l'objet principal.

J'ai déjà essayé de changer l'objet principal en CreateDynamicObject, mais je pense qu'on m'a jeté un sortilège, car voilà, ça ne fonctionne pas !

 

Si quelqu'un possède la solution, ce serait hibou de me dire où je me suis lamentablement vautré !

 

P.-S.: Pour vous encourager à bosser, voici la créature hyper mignonne que vous m'aidez à faire !sa-mp-117.thumb.png.d77636cbdb117fb0dc7e352a693e02b8.png

Modifié par IncroyablePix
1 personne aime ça

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @IncroyablePix la fonction AttachDynamicObjectToObject dépend du plugin YSF, il te suffit de regarder dans ta console ^_^

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui, en effet, merci !

Partager ce message


Lien à poster
Partager sur d’autres sites
Guest
Ce sujet ne peut plus recevoir de nouvelles réponses.