Aller au contenu
San Andreas Multiplayer

Messages recommandés

LSMemories 1.0

Voir le fichier

 

 

LSMemories.net est un gamemode sous la base de South Central Roleplay (http://forum.sa-mp.com/showthread.php?t=538107) crée par Emmet.
---------------------------------------
CONFIGURATION DU SERVEUR :
    1. Installation de la base de donnée :
        Il est nécéssaire d'installer votre base de donnée (lsmemories.sql) avant de lancer votre serveur.
    2. Connexion de votre base de donnée :
        Une fois la base de donnée installée, indiquez les identifiants de connexions dans les 4 macros suivantes (ligne 23 à 26):
            SQL_HOSTNAME: Nom d'hôte (par défaut "localhost")
            SQL_USERNAME: Nom d'utilisateur MySQL
            SQL_DATABASE: Nom de la base de donnée
            SQL_PASSWORD: Mot de passe MySQL
    3. Paramétrez les informations relatives au serveur :
        Pour changer le nom d'hôte, le lien du site internet, la langue et la map il faut vous rendre directement dans la gamemode (ligne 28 à 32):
            SERVER_NAME: Nom du serveur
            SERVER_URL: Lien de votre site internet
            SERVER_MAP: Nom de la map (uniquement sur les versions < 0.3.7)
            SERVER_LANG: Language par défaut du serveur
            SERVER_REVISION: Version du serveur
    
-----------------------------------------
ERREURS PROBABLES :
    1. Le serveur affiche "Unknown" :
        Installer le plugin "nativechecker", charger le dans votre fichier de configuration (server.cfg) et postez les logs sur le sujet de support.
    
-----------------------------------------
Well done! Vous êtes prêt pour lancez votre serveur.

 


 

Modifié par SUNSHINE.
  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est quelle version ? Celle qui a commencé a être debug ou l'originale ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Papawy a dit :

C'est quelle version ? Celle qui a commencé a être debug ou l'originale ?

L'originale, il n'y aucune de nos modifications.

Partager ce message


Lien à poster
Partager sur d’autres sites

Kozik, je pense aussi car j'ai essayé avec la base de données fourni voir ce que cela donne en jeu, mais dès que je me connecte rien se passe à part les textdraw avec écrit LSMemories

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah regarder se qui manque ce nest pas un plug n play comme un sarp travailler un peut...

Modifié par Tysanio

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso j'ai réussi à le lancer, mais ça fait chier de viré le système d'inscription, la flemme de re créer les tables, sunshine devrait remettre la bonne , j'espère que c'est pas voulu les erreurs

 

EDIT: Il faut la bdd, trop de système qui fonctionne pas sans la bonne, c'est dommage le gm est intéressant, mais la french bug community a encore frappé

Modifié par Kozik

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est simplement une erreur de ma part, je vais mettre la bonne base (celle correspondant à la version actuelle) d'ici la fin de la soirée.

Partager ce message


Lien à poster
Partager sur d’autres sites

La base de donnée a été mise à jour dans l'archive RAR.

Je l'ai mise aussi en pièce jointe de ce message.

lsmemories.sql

 

 

N'hésitez pas à me signaler tout problème lors du démarrage du serveur et de signaler les éventuels bugs rencontrés, si j'ai un peu de temps je verrais pour faire des patchs correctifs au fil du temps.

Modifié par SUNSHINE.
  • J'aime 3

Partager ce message


Lien à poster
Partager sur d’autres sites
Guest

Le bug le plus connu est celui du spec, on vous proposera peut-être un hotfix, mais vous pouvez le régler facilement, en gros, parfois le joueur voit tout disparaitre autour de lui, ça vient du /spec.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, rayS a dit :

ça vient du /spec.

et du Nexus AC, j'avais compris le bug

Partager ce message


Lien à poster
Partager sur d’autres sites

Soucis d'id dans la création des véhicules, les id se décales et prennent des nombres comme 540 ça vient de Car_Create il m'semble j'vous redit après

Partager ce message


Lien à poster
Partager sur d’autres sites
31 minutes ago, Kozik said:

Soucis d'id dans la création des véhicules, les id se décales et prennent des nombres comme 540 ça vient de Car_Create il m'semble j'vous redit après

se qui a cest que cest pas SARP les id vehicule on sen tap sa charge parfait sa load tout les vheicule cool on veux en supprimer un? DONE sa ne fait rien a la bdd ;P

Partager ce message


Lien à poster
Partager sur d’autres sites

Je trouve un soucis de mon côté, le serveur se lance sans problème, mais une fois que je me connecte j'ai la souris SAMP avec les textdraw écris LSMemories.net mais rien ne s'affiche.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Synoka a dit :

Je trouve un soucis de mon côté, le serveur se lance sans problème, mais une fois que je me connecte j'ai la souris SAMP avec les textdraw écris LSMemories.net mais rien ne s'affiche.

J'ai cru lire qu'il faut la nouvelle bdd 

 

Sinon sympa de partager c'est surement une bonne base :) 

Partager ce message


Lien à poster
Partager sur d’autres sites

Certains avaient des problèmes avec la base de donnée lors de l'inscription de leur personnage, j'ai fais un patch correctif (disponible ci-dessous ou dans l'archive).

lsmemories.sql

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, j'ai trouver des soucis dans ton script le système de taxi (les bots bug), le système de dashcam aussi et un problème d'ID avec les meuble et les étagères dans la même maison.

 

Sinon beau GameMode :D

Modifié par Brust

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 30 minutes, Brust a dit :

les bots bug

Tu parles du fait qu'ils ne sont pas à "leur position exacte" ? Car si c'est ça, c'est pas un bug du script mais de SA:MP.

 

Sinon pour les autres, quels sont les bugs exacts ?

Partager ce message


Lien à poster
Partager sur d’autres sites

@SUNSHINE. Non c'est pas sa, quand on reçoit un appel d'un bot et qu'on y va sur place le bot ne fait rien, en gros une fois qu'on arrive au checkpoint du bot plus rien ne ce passe après. 

Le bug de la dashcam c'est qu'elle ne fonctionne pas du tout, quand on tape la commande on tombe dans le vide.

Et pour le bug des étagères, quand tu pose une étagère, tu save la position, tu spawn un meuble, tu save la position et c'est l'étagère qui vient récupéré la position du meuble.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ne demandez pas d'aide à une personne qui poste un gamemode pour vous corriger tous les bugs (excepté le problème de la bdd).

Si vous savez suffisamment programmer, vous serez aptes à les corriger vous-même.

  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...